UI bug causing crashes
Incident Report for Stacker
Resolved
This issue has now been resolved. Please refresh your browsers if you're still having issues.
Posted Mar 08, 2021 - 19:42 UTC
Investigating
We're currently investigating an issue that's causing some browsers to lock up when adding new records into link fields
Posted Mar 08, 2021 - 19:32 UTC
This incident affected: Stacker App.